传奇版本,传奇服务端,GM基地,传奇论坛,开区一条龙

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 1706|回复: 13

[GM88教程] 第二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关

[复制链接]
  • TA的每日心情
    开心
    2018-10-29 20:59
  • 签到天数: 425 天

    [LV.9]赤月称雄

    1608

    主题

    1930

    帖子

    1万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    10221
    发表于 2018-7-13 16:03:46 | 显示全部楼层 |阅读模式
    第二课-服务器和网关对接,TOKEN验证及算法。
    ------------------------------------TOKEN源码
    .子程序 TOKEN验证
    .参数 GET数据, 文本型
    .参数 当前客户, 文本型
    .局部变量 字符验证, 文本型
    .局部变量 GET分割, 文本型, , "0"
    .局部变量 数组重新排序, 文本型, , "0"
    .局部变量 验证码, 文本型
    .局部变量 数据加密, 类_数据操作
    .局部变量 数据对比, 文本型

    字符验证 = 子文本替换 (GET数据, “signature=”, “”, , , 真)
    字符验证 = 子文本替换 (字符验证, “echostr=”, “”, , , 真)
    字符验证 = 子文本替换 (字符验证, “timestamp=”, “”, , , 真)
    字符验证 = 子文本替换 (字符验证, “nonce=”, “”, , , 真)
    .如果真 (寻找文本 (字符验证, “&”, , 假) = -1)
        日志输出 (“TOKEN验证失败..”)
        返回 ()
    .如果真结束
    GET分割 = 分割文本 (字符验证, “&”, )
    加入成员 (数组重新排序, GET分割 [3])
    加入成员 (数组重新排序, GET分割 [4])
    加入成员 (数组重新排序, _启动窗口.编辑框_微信接口_TOKEN.内容)
    数组_排序 (数组重新排序, , )
    验证码 = 数组重新排序 [1] + 数组重新排序 [2] + 数组重新排序 [3]
    数据对比 = 数据加密.hex_sha1 (到字节集 (验证码))
    .如果真 (GET分割 [1] = 数据对比)
        日志输出 (“TOKEN验证成功...”)
        服务器返回数据 (当前客户, #wx_协议头 + 时间_转为GMT格式 (取现行时间 ()) + #换行符 + #换行符 + GET分割 [2])
        返回 ()
    .如果真结束
    日志输出 (“TOKEN验证失败...”)
    服务器返回数据 (当前客户, GET分割 [1])

    游客,如果您要查看本帖隐藏内容请回复






    上一篇:第一课-易语言安装和公众号基本介绍-微信公众号传奇网关
    下一篇:第3课-用户关注触发及保存用户信息到数据库,传奇微信公众号开发
    回复

    使用道具 举报

    该用户从未签到

    0

    主题

    2

    帖子

    8

    积分

    英勇青铜

    Rank: 1

    积分
    8
    发表于 2019-1-10 18:26:16 | 显示全部楼层
    dierfgdasfs
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    18

    帖子

    46

    积分

    英勇青铜

    Rank: 1

    积分
    46
    发表于 2019-1-26 15:27:00 | 显示全部楼层
    都要学习一下
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    20

    帖子

    29

    积分

    英勇青铜

    Rank: 1

    积分
    29
    发表于 2019-3-18 20:45:22 | 显示全部楼层
    这个系列我一集也不想错过
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    4

    帖子

    14

    积分

    英勇青铜

    Rank: 1

    积分
    14
    发表于 2019-3-30 10:17:39 | 显示全部楼层
    二课-服务器和网关对接,TOKEN验证及
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    4

    帖子

    11

    积分

    英勇青铜

    Rank: 1

    积分
    11
    发表于 2019-8-1 23:40:27 | 显示全部楼层
    二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关 [修改]
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    3

    帖子

    11

    积分

    英勇青铜

    Rank: 1

    积分
    11
    发表于 2019-9-23 17:22:47 | 显示全部楼层
    课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关 [修改]
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    13

    帖子

    21

    积分

    英勇青铜

    Rank: 1

    积分
    21
    发表于 2019-10-17 15:05:58 | 显示全部楼层
    ffffffffffffff
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    2

    帖子

    8

    积分

    英勇青铜

    Rank: 1

    积分
    8
    发表于 2019-12-17 13:57:13 | 显示全部楼层
    6666666666666666666666
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    2

    帖子

    8

    积分

    英勇青铜

    Rank: 1

    积分
    8
    发表于 2019-12-17 17:48:10 | 显示全部楼层
    第二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关 [
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 会员注册

    本版积分规则

    QQ:2444100141|小黑屋|手机版|传奇版本  

    GMT+8, 2020-5-27 08:11 , Processed in 0.242207 second(s), 34 queries , Gzip On.

    Powered by Discuz!

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表